Friday, April 11, 2008

Installing Pidgin on RHEL5

It's over an year since the last time i wrote something about pidgin on my blog.

Yesterday one of my friends installed her machine with RedHat Enterprise Linux 5, the OS that i have come to like so very much ;). During the installation she had forgotten to go in to the detailed package selection dialogs -probably because, on the text mode installation, anaconda keeps the package details hidden in a dialog which you have to access by pressing a function key- and ended up not having pidgin on her installation.

A new comer to pidgin, she then went on and downloaded the Pidgin RHEL5 RPMs from the Official pidgin RHEL/CentOS 5 yum-repo as i have told her at a previous time.

The problem here is like this.
You can't just install the RPMs from there, as they seem to have a few dependencies, most of them are for the package libpurple.

Now this by it self is not a problem at all, if you have been using RHEL for sometime, then you would know how to figure out the missing packages from the rpm dependancy error messages, which is what i started doing.

There were few packages like cyrus-sasl-MD5 and gtkspell which fixed a lot of errors, but this error regarding some libsilc and silc-client which just wouldn't go away.

The funny thing is, when you google for libsilc or silc-client you don't get anything that you can work on really. Yes, it does give you this site http://silcnet.org which seem to belong to them who maintain this component. Little look on to the site revealed that SILC is actually a method or a protocol for secure conference (chat).

It actually took me a while to try and install the packages that are there..as they seem to be for Fedora 7, and i wasn't very sure how it might affect the system.

SILC Client 1.1.4
SILC Toolkit 1.1.7

Finally, as i couldn't find any RPM for RHEL5 which fulfills my missing packages, i went ahead with the installation of these two packages.

The problem still remained, and kept giving me an error.
Then i tried a 3rd link from the same site.

SILC Pidgin 2.4.0 and after clicking through few links i ended up on a Fedora mirror. I tried searching for the word silc and found this package libsilc which did the job for me finally.

So far i have not been able to find a matching set of RPMs for RHEL5 which would install pidgin without a problem, its quite possible im looking at wrong places, but am i. Only place i didn't look in to yet is the CentOS 5 mirrors which could have all i need. But what i'm wondering is what has happned to all these RPM sites with huge collections of RPM, which have been doing a damn good job by the way over the years...

Perhaps i should try my hand at creating a few RPMs on my own, and only problem there is i don't yet know how..but hey, rome wasn't built in one day, rite?

3 comments:

Croissont said...

thanks for the tips dude. it really sux ćause I so wanna use Pidgin and it keeps showing me dependency errors. I hope the fix it and I also hope you get it fixed. hehe.

chanda said...

i m still getting following error while installing pidgin.
Error: Missing Dependency: libgtkspell.so.0()(64bit) is needed by package pidgin
Error: Missing Dependency: cyrus-sasl-md5 is needed by package libpurple
Error: Missing Dependency: libsilcclient-1.0.so.1()(64bit) is needed by package libpurple
Error: Missing Dependency: libnssutil3.so()(64bit) is needed by package libpurple
Error: Missing Dependency: libsilc-1.0.so.2()(64bit) is needed by package libpurple
even though i install libpurple...can u help me out

Bob said...

the link you gave 404'd on me. But it gave me enough clue to go look here:

http://pidgin.im/pipermail/devel/2007-August/002407.html

which has a solution